Why can't I install or run the app?

There are some minimum requirements needed to use the application, you can review them on the Download page, clicking here. In general, you must have a Windows 10 containing the 2H20 update from October 2020. For Android you must have an Android 6 from October 2015 or higher and must have support for OpenGL ES 3.0. The browser still needs support for WebAssembly and WebGL, being optimized for Safari and Chrome.

Do you want to stay on top of what is the latest?

Check out what is the latest on our blog to get more likes and followers.